Skip to main content

Picture Issue: TV has sound but no picture

Please follow the instructions below to troubleshoot the TV

Step 1:

  1. Unplug the TV cord from the power socket
  2. Leave it unplugged and while it's unplugged press and hold the Power button on the TV for 25 seconds
  3. Release the power button and plug the cord back in. Turn ON the TV using the remote control or manually and check if there's picture on the Screen

If the issue persist then follow the next step...

Step 2:

Factory Reset the TV using the RESET option (a pin hole) on the back of the TV which is located just above the HDMI port. Use a pin and press & hold it for 30-60 seconds for the TV to Reset and Restart

Note: IF the issue persists then please contact our Customer Support Team at 888-842-3577

Was this article helpful?
1 out of 11 found this helpful

Comments

11 comments
  • None of these troubleshooting tips worked for me

    0
  • They couldn`t help anymore than this page did when I called them after following the steps here they say to call my question is WHY they are incapable of doing anything beyond that will not buy another element poor service and short life span. They told me to either buy another TV or take it to a repair shop. PITIFULL¬†

    1
  • None of these steps worked. My tv was only 1 year old!

    0
  • My TV is 4 days old and suddenly has no picture. These steps didn't help me.

    0
  • No picture everything else works light blue screen in middle black around corners three white dots in centre.changed battery's in remote still not working in plugged tv nothing.reset tv nothing .model no. Ona50ub19e05

    1
  • I did the reset..and was on the phone with a tech... He said because there is a red line. That the phone has a default

    -1
  • went thur all steps and would get picture for about 5 min.

    0
  • This is the second element tv I have purchased. First was in sense element and now Roku element. Both went to black screen after only a year old and support and company offer no help. Poorest quality tv ever and I will advise everyone that this company sucks!!!!!

    0
  • Guys, this advice helped me. I was going round in circles and followed the steps to the letter.

    TV now gets the picture again.

     

    Thanks.

    -1
  • None of the settings steps are helping

    0
  • I tried it and it worked. I unpluged the cord, held the power button ON THE TV for 25 seconds, plugged back in, and then turned on WITH THE REMOTE. Make sure to follow steps to the tee.

    0

Please sign in to leave a comment.

Powered by Zendesk